Tighten Fuel Cap message - AcuraZine Community
AcuraZine Acura Forums Home Acura CL Forums Acura ILX Forums Acura MDX Forums Acura NSX Forums Acura RDX ForumsAcura RL ForumsAcura RSX ForumsAcura TL ForumsAcura TSX ForumsAcuraZine ZDX DiscussionAcuraZine Regional DiscussionAcuraZine Off Topic Discussion

Go Back   AcuraZine Community > AcuraZine TSX Community > First Generation TSX Discussion (2004-2008) > Problems & Fixes
Sign in using an external account
Register Forgot Password?
Register Albums FAQ Members Calendar Search Today's Posts Mark All Read ExperienceUsed CarsVendorsGarage
Search
Welcome to AcuraZine Community

Notices

Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread
Old 01-10-2008, 9:22 PM   #1
littleorangeman
Registered Member
Garage is empty, add now
 
littleorangeman's Avatar
 
Trader Rating: (0)
Join Date: Jun 2006
Location: st. louis
Age: 35
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 3,997, Level: 40
Points: 3,997, Level: 40 Points: 3,997, Level: 40 Points: 3,997, Level: 40
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Tighten Fuel Cap message

first i'd like to say that i did a brief search around the forum for this subject, but didnt find anything that fit my situation. if you know of a thread that solves my problem please post it. apologies if this is a re-tread thread...

went out on my lunch break to fill my car up with gas. as soon as i turned it on the warning bell sounded and i get this message "Tighten Fuel Cap" (or something along those lines). i hadnt gotten the gas yet, and my fuel door and cap were securely closed and tightened (hadnt touched them in a week). anyway, i got out, made sure the cap was tight -- it was -- and went on my way. the warning message did not go away. i thought it would go away after the next time i started my car, but it didnt. then i thought it may be a pressure issue in the gas tank and that it would go away after i got gas since i would be unfastening and refastening the cap. nope. it has stayed on despite 4-5 engine starts and about 40 miles of driving at upwards of 75mph. the reason why i state the mileage and mph is because the owner's manual says that if the light stays on it may not go off until you go over 35mph or drive around for a bit. i dont really know what else to do except call acura and have them look at it.

now, here are the details:
  • 2006 TSX
  • ~27k-28k miles
  • i was between 1/8 and 1/4 of a tank when i pulled into work this morning -- not entirely unusual. i usually refuel right around when the "Get Fuel" light comes on which is with an estimated 30-40 miles left in my tank (or between 1/8 and 1/4 tank).
  • it was cold this morning, around 35F; and around 40F and rainy at lunch when the light came on.
my initial guess is that the cold, humid air combined with the low fuel and created lower pressure in the fuel tank and thus made the car think the gas cap was off or not screwed on tightly enough. but now that ive taken it off and on, refueled and driven many miles with the warning still on i simply dont know what to do.

thanks in advance for any advice/help you can give,
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Acurazine!
__________________
2006 TSX CGP 5AT non-Navi

* no mods until I get my own garage
littleorangeman is offline   Reply With Quote
Old 01-11-2008, 9:43 AM   #2
925tsx
B A N N E D
Garage is empty, add now
 
925tsx's Avatar
 
Trader Rating: (0)
Join Date: Sep 2003
Location: Jerzey
Age: 34
Posts: 858
Thanks: 0
Thanked 0 Times in 0 Posts
It will go off, u might need to give it a week.

When i had my 04, this happened. Only difference is on the 04, there was no MID, so my check engine light came on. It was because the gas cap was not tightened. It took a week and a half for the light to shut off. (after i tightened the cap)
925tsx is offline   Reply With Quote
Old 01-11-2008, 10:15 AM   #3
littleorangeman
Registered Member
Garage is empty, add now
 
littleorangeman's Avatar
 
Trader Rating: (0)
Join Date: Jun 2006
Location: st. louis
Age: 35
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Threadstarter
Points: 3,997, Level: 40
Points: 3,997, Level: 40 Points: 3,997, Level: 40 Points: 3,997, Level: 40
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
even tho the gas cap was never loose? thats what concerns me here. i hadnt touched the gas cap in a week. and all of a sudden it tells me that i need to tighten it. i got out, made sure it was tight -- which it was -- and then drove off with the light still on. after getting gas later and driving around its still on. i can understand if the message came on because the cap was actually not on or loose, and then having it take a week to go off. but since mine was securely tightened im afraid that this warning may indicate something else. unless of course, that is, you or other people around here think the warning could have gone off because of what i thought -- the low temp, low gas and humidity upon start up. but i dont want to be driving it around for a week if this warning could indicate something else, something more gut wrenching if i dont take care of it now...
littleorangeman is offline   Reply With Quote
Old 01-11-2008, 11:29 AM   #4
LukeaTron
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Aug 2007
Location: Pittsburgh, PA
Age: 36
Posts: 2,545
Thanks: 0
Thanked 1 Time in 1 Post
Points: 5,059, Level: 45
Points: 5,059, Level: 45 Points: 5,059, Level: 45 Points: 5,059, Level: 45
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
I wouldn't be worried. Gasoline changes volume fairly dramatically with temperature. My bike pees on the floor if I top it off in the late, cool evening. Even if there is some other problem it's not likely to be one that will cause you damage by ignoring it. If in a week or so it's still on, then you might want to have it checked out. That warning stays on for a madenningly long time.
LukeaTron is offline   Reply With Quote
Old 01-11-2008, 11:50 AM   #5
littleorangeman
Registered Member
Garage is empty, add now
 
littleorangeman's Avatar
 
Trader Rating: (0)
Join Date: Jun 2006
Location: st. louis
Age: 35
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Threadstarter
Points: 3,997, Level: 40
Points: 3,997, Level: 40 Points: 3,997, Level: 40 Points: 3,997, Level: 40
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
ok cool
thanks guys
i'll let you know what happens in a week or so.
littleorangeman is offline   Reply With Quote
Old 01-11-2008, 8:00 PM   #6
littleorangeman
Registered Member
Garage is empty, add now
 
littleorangeman's Avatar
 
Trader Rating: (0)
Join Date: Jun 2006
Location: st. louis
Age: 35
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Threadstarter
Points: 3,997, Level: 40
Points: 3,997, Level: 40 Points: 3,997, Level: 40 Points: 3,997, Level: 40
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
it's like my car knew i was talking about it. went to leave for lunch today and had no warning message come on. same thing when i left work in the evening. thanks again for quelling my fears guys.
littleorangeman is offline   Reply With Quote
Old 01-12-2008, 3:06 AM   #7
proudacuraownr
2005 Acura TL
Garage is empty, add now
 
proudacuraownr's Avatar
 
Trader Rating: (0)
Join Date: Jan 2007
Location: Seattle,WA
Age: 24
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
You may just have to replace the gas cap.
proudacuraownr is offline   Reply With Quote
Old 01-15-2008, 3:52 AM   #8
WICKEDFX
Registered Member
Garage is empty, add now
 
WICKEDFX's Avatar
 
Trader Rating: (0)
Join Date: Apr 2006
Age: 34
Posts: 205
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 6,569, Level: 53
Points: 6,569, Level: 53 Points: 6,569, Level: 53 Points: 6,569, Level: 53
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
your car wants more modifications. It's finding a way to tell you.

I am having the same problem. Been 4 days now and still waiting for it to turn off.
WICKEDFX is offline   Reply With Quote
Old 02-24-2008, 12:38 PM   #9
jschaer
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Feb 2008
Age: 36
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Have the same message...

Got this message this week after leaving the gym... Filled up the tank about three days before the message went on, but in hindsight, it went off after a dramatic rise in temp then drop outside (went from mid 30's to almost 60 to mid 20's... I hate New Jersey)...

Glad to see that it will eventually reset itself - was at the dealer yesterday to have my grille replaced (chrome was chipping off - I want the Mugen grille, but no cash and dealer grille was under warranty) and the dealer told me the light would reset - I thought he was selling me a line of bs.... good to know I don't have to go back and kick his butt...
jschaer is offline   Reply With Quote
Old 02-28-2008, 2:09 AM   #10
FRANTSX
Registered Member
Garage is empty, add now
 
FRANTSX's Avatar
 
Trader Rating: (0)
Join Date: Apr 2006
Location: Bay Area, CA
Age: 42
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Me too..

Guys, I have been having the same problem since summer. It comes and goes. It just came out of nowhere back in September 07, in hot weather. Then I tightened the cap and it went away. The light stayed off for about two weeks, then after I filled up, it came back on again. I always try to tighten it extra tight now but it stays the same, comes and goes. What to do? Do I need a new gas cap?
FRANTSX is offline   Reply With Quote
Old 05-28-2009, 3:19 PM   #11
frank212
New Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: May 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
fuel cap warning

i have a 2008 TL type S and I've been getting that tighten fuel cap warning for over 7 months now. In the beginning it only came on once in a while stayed on for a couple of day and then i wouldn't see it for months. Now it comes on every other day stays lit for a couple of minutes and then turns off. Usually goes on after about 30 minutes of driving in around 60 degree temperature. The warm it gets the more it goes on and off on and off. some days when its warm it comes on about 6 or 7 times on the 1 hour drive. The reason I know it goes on so much is because every single time it cycles on i get a message on the navigation system. That gets annoying it talks for a good 30 seconds each time telling me to check the fuel cap not to mentions its an embarrassment when someone is in the car with you. I've been to the dealer many times for this issue at-least 7 times now. the first time they tightened it and reset the computer it came on again after 4 days. then they were telling me its the way i pump the gas. Finally the last time i went there they told me alot of 2008 tl's type s are having the same problem acura is working on the problem. from reading all of these messages here it seems to me the problem is not only on the 2008 tl but almost every year before it too.
frank212 is offline   Reply With Quote
Old 05-28-2009, 7:01 PM   #12
mjjd94
New Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: May 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Tighten Fuel Cap Message

I have a 2007 MDX and have received this warning message as well. The first time, I loosened the cap and tightened past 3 clicks and the warning message went away after a few miles of driving. Today it appeared again (been several months since the last time) and has not gone off despite complete removal and retightening. I am at 1/2 tank. I can't believe it's the weather since it doesn't do this when there are cool temperatures. I'm inclined to think it's a bug in their sensors / software based on the comments from others in the forum. Wish I had a solution to post, but I'm just sharing the frustration with this problem.
mjjd94 is offline   Reply With Quote
Old 05-29-2009, 9:21 AM   #13
npolite
Registered Member
Garage is empty, add now
 
npolite's Avatar
 
Trader Rating: (0)
Join Date: Dec 2007
Location: Drexel Hill, PA
Age: 36
Posts: 583
Thanks: 1
Thanked 3 Times in 3 Posts
Points: 6,316, Level: 51
Points: 6,316, Level: 51 Points: 6,316, Level: 51 Points: 6,316, Level: 51
Activity: 0.7%
Activity: 0.7% Activity: 0.7% Activity: 0.7%
Quote:
Originally Posted by mjjd94 View Post
I have a 2007 MDX and have received this warning message as well. The first time, I loosened the cap and tightened past 3 clicks and the warning message went away after a few miles of driving. Today it appeared again (been several months since the last time) and has not gone off despite complete removal and retightening. I am at 1/2 tank. I can't believe it's the weather since it doesn't do this when there are cool temperatures. I'm inclined to think it's a bug in their sensors / software based on the comments from others in the forum. Wish I had a solution to post, but I'm just sharing the frustration with this problem.
It does have to do with the warmer weather. Gasoline creates a higher pressure when it is warmer which is causing some sensor to go haywire. You can see the issue with a gas can when you release the pressure from it. Usually when it is cooler it is less than when it is 90 degrees.
__________________
2009 Altima 2.5 SL - 95k miles - Auto - Sister's
2007 TSX - Auto - 67k miles mine
2012 Toyota Camry - 5k miles Mom's
1999 Accord LX Sedan - Auto - 103k miles Dad's
npolite is offline   Reply With Quote
Old 05-29-2009, 9:41 AM   #14
npolite
Registered Member
Garage is empty, add now
 
npolite's Avatar
 
Trader Rating: (0)
Join Date: Dec 2007
Location: Drexel Hill, PA
Age: 36
Posts: 583
Thanks: 1
Thanked 3 Times in 3 Posts
Points: 6,316, Level: 51
Points: 6,316, Level: 51 Points: 6,316, Level: 51 Points: 6,316, Level: 51
Activity: 0.7%
Activity: 0.7% Activity: 0.7% Activity: 0.7%
Also just to let you know, my sister just got the same problem on her 08 Accord. It happened just when she was leaving work and that's when the sun is hitting the car.
__________________
2009 Altima 2.5 SL - 95k miles - Auto - Sister's
2007 TSX - Auto - 67k miles mine
2012 Toyota Camry - 5k miles Mom's
1999 Accord LX Sedan - Auto - 103k miles Dad's
npolite is offline   Reply With Quote
Old 05-09-2011, 9:59 AM   #15
miltontls
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Apr 2011
Age: 25
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 1,689, Level: 23
Points: 1,689, Level: 23 Points: 1,689, Level: 23 Points: 1,689, Level: 23
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
yea i have a 2008 tl-s with 54k and i have the same problem,
miltontls is offline   Reply With Quote
Old 05-09-2011, 9:14 PM   #16
DuckDodgers
in the 24th and a half...
Garage is empty, add now
 
DuckDodgers's Avatar
 
Trader Rating: (0)
Join Date: Mar 2006
Location: TX
Age: 48
Posts: 851
Thanks: 3
Thanked 35 Times in 34 Posts
Points: 7,351, Level: 57
Points: 7,351, Level: 57 Points: 7,351, Level: 57 Points: 7,351, Level: 57
Activity: 2.6%
Activity: 2.6% Activity: 2.6% Activity: 2.6%
Just remember it can take a number of start-stop cycles to reset the warning message/light. I have heard anywhere from 10 to 20 cycles.
DuckDodgers is offline   Reply With Quote
Old 05-10-2011, 7:30 AM   #17
nj2pa2nc
it's a car-drive it
Garage is empty, add now
 
nj2pa2nc's Avatar
 
Trader Rating: (0)
Join Date: Apr 2007
Location: North Carolina
Posts: 5,340
Thanks: 453
Thanked 252 Times in 190 Posts
pm me
Points: 9,184, Level: 64
Points: 9,184, Level: 64 Points: 9,184, Level: 64 Points: 9,184, Level: 64
Activity: 1.1%
Activity: 1.1% Activity: 1.1% Activity: 1.1%
Quote:
Originally Posted by DuckDodgers View Post
Just remember it can take a number of start-stop cycles to reset the warning message/light. I have heard anywhere from 10 to 20 cycles.
the 2 times it happened with my car the message would not disappear. I had the dealer reset it-
__________________
2006 MR/eb 6MT/wnav tsx (new 11/17/06) 166k
miles(regular gas), rear brakes replaced 1st time 150k miles front brakes still in great shape. Original owner-it is my official beach going, dog carrier vehicle. 2014 Kia Soul primo package (new -1/03/14) official roadtrip vehicle. (3K miles)
nj2pa2nc is offline   Reply With Quote
Old 05-10-2011, 12:49 PM   #18
kipsy
Registered Member
Garage is empty, add now
 
kipsy's Avatar
 
Trader Rating: (0)
Join Date: Dec 2005
Posts: 122
Thanks: 0
Thanked 2 Times in 2 Posts
Points: 6,771, Level: 54
Points: 6,771, Level: 54 Points: 6,771, Level: 54 Points: 6,771, Level: 54
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
they say they reset it to me as well, but i also found a bright blue new gasket on my fuel cap that was not noted on the bill ...
__________________
*2006 tsx AT deep green pearl/parchment,silver int trim-no wood,oem all-weather mats,bridgestone turanzas,civic 16" alloys/blizzaks,acuracare 8y120k
*2011 toyota highlander blizzard pearl base v6 4wd,ebay roof rack,hood deflector,rav4 wheels/blizzaks,weathertechs,platinum-care 7y100k
*2013 honda civic LX
kipsy is online now   Reply With Quote
Old 05-10-2011, 5:37 PM   #19
07BLKACURA
Registered Member
2007 Acura TL
 
Trader Rating: (0)
Join Date: May 2011
Age: 32
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Hey, I have a 07 Acura TL and my "tighten fuel cap" message has been appearing since I bought the car in Nov '10. I recently replaced the cap and now the message comes on every couple hours. At least with the old one, it only came on every few days. I've read the posts and so far the only suggestions have been to replace cap or reset it. Is there a chance it could be a faulty sensor?

Thx
07BLKACURA is offline   Reply With Quote
Old 05-11-2011, 10:10 AM   #20
nj2pa2nc
it's a car-drive it
Garage is empty, add now
 
nj2pa2nc's Avatar
 
Trader Rating: (0)
Join Date: Apr 2007
Location: North Carolina
Posts: 5,340
Thanks: 453
Thanked 252 Times in 190 Posts
pm me
Points: 9,184, Level: 64
Points: 9,184, Level: 64 Points: 9,184, Level: 64 Points: 9,184, Level: 64
Activity: 1.1%
Activity: 1.1% Activity: 1.1% Activity: 1.1%
Quote:
Originally Posted by kipsy View Post
they say they reset it to me as well, but i also found a bright blue new gasket on my fuel cap that was not noted on the bill ...
the dealer did not do anything with my fuel cap.
__________________
2006 MR/eb 6MT/wnav tsx (new 11/17/06) 166k
miles(regular gas), rear brakes replaced 1st time 150k miles front brakes still in great shape. Original owner-it is my official beach going, dog carrier vehicle. 2014 Kia Soul primo package (new -1/03/14) official roadtrip vehicle. (3K miles)
nj2pa2nc is offline   Reply With Quote
Old 05-11-2011, 12:17 PM   #21
proimport
Registered Member
Garage is empty, add now
 
proimport's Avatar
 
Trader Rating: (0)
Join Date: May 2009
Location: va
Age: 35
Posts: 484
Thanks: 0
Thanked 20 Times in 20 Posts
redline96
Points: 4,355, Level: 42
Points: 4,355, Level: 42 Points: 4,355, Level: 42 Points: 4,355, Level: 42
Activity: 1.3%
Activity: 1.3% Activity: 1.3% Activity: 1.3%
My 07 tls did the same thing so I took it the dealer they changed the gas cap and reset something it was free
__________________
07 WDP TL Type S
proimport is offline   Reply With Quote
The Following User Says Thank You to proimport For This Useful Post:
mixjuan (02-18-2012)
Old 05-28-2011, 4:21 PM   #22
hagfan72
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: May 2011
Location: Honolulu, Hawaii
Age: 41
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 1,772, Level: 24
Points: 1,772, Level: 24 Points: 1,772, Level: 24 Points: 1,772, Level: 24
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
My '07 TSX got this warning for the first time a few days ago. Wife said that the cap was indeed loose when she checked it. It only today went out, after two days, a few dozen miles, and several key cycles. BTW, great forum I found here. Looking forward to learning more about my TSX. After buying it, I found evidence that it had been in a pretty severe wreck, so I am sure I will have lots of little annoying problems that I can discuss on here. LOL
hagfan72 is offline   Reply With Quote
Old 06-16-2011, 11:05 PM   #23
vt4lifecuf
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Oct 2005
Location: Orlando
Age: 29
Posts: 226
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 5,477, Level: 47
Points: 5,477, Level: 47 Points: 5,477, Level: 47 Points: 5,477, Level: 47
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
i had the same problem on my 07 TLS replace purge control solenoid should correct the problem.
vt4lifecuf is offline   Reply With Quote
Old 07-12-2011, 8:03 AM   #24
Yerny
Registered Member
1966 Chevrolet Nova
My Garage
 
Trader Rating: (0)
Join Date: Jul 2011
Location: Falls Church, VA
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 385, Level: 7
Points: 385, Level: 7 Points: 385, Level: 7 Points: 385, Level: 7
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Just bought an '06 TL w/ 78K miles on it, gas light was on. It took 3 refills to go off, I just hope it stays off now.
Yerny is offline   Reply With Quote
Old 07-19-2011, 10:25 AM   #25
Brooklynn
New Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Jul 2011
Location: Los Angeles
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
Points: 1,180, Level: 18
Points: 1,180, Level: 18 Points: 1,180, Level: 18 Points: 1,180, Level: 18
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
My girlfriends and I installed a K & N stock air filter in our alpine White Acura TL-S and started to experience the same thing with our "tighten gas cap" indicator. It only started when we upgraded to the k&N filter. We took it off and the indicator came off. But we love how the K& N filter allows our engines to breathe, so we put it back on. So far the indicator comes and goes, especially when we ride it hard!!
Brooklynn is offline   Reply With Quote
The Following User Says Thank You to Brooklynn For This Useful Post:
mixjuan (02-18-2012)
Old 07-20-2011, 3:36 PM   #26
beachbobe
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Oct 2003
Location: Newburyport, MA
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
Points: 5,743, Level: 48
Points: 5,743, Level: 48 Points: 5,743, Level: 48 Points: 5,743, Level: 48
Activity: 0.1%
Activity: 0.1% Activity: 0.1% Activity: 0.1%
Thanks to all above - I hope

I have had this problem every summer for past 2 years. "Tighten Fuel Cap" msg appears intermittently especially when the air temp is above 80 degrees. After reading all the previous posts I gave the dealer the service bulletin number 09-056 that others have reported and they replaced purge solenoid. I live in pricey Boston area - out of warranty dealership price was $128 for parts and about $60 for labor. 2007 TL Hope this works!
beachbobe is offline   Reply With Quote
The Following User Says Thank You to beachbobe For This Useful Post:
mixjuan (02-18-2012)
Old 08-15-2011, 12:31 PM   #27
mkbqin
New Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Apr 2010
Age: 36
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Points: 2,865, Level: 32
Points: 2,865, Level: 32 Points: 2,865, Level: 32 Points: 2,865, Level: 32
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Purge Control Sensor

Hey Guys, Thanks for the info, it helped. I have an '07 Tl-S and this has been happening to me off an on for about 6 - 7 months. Service the car at Sunnyside Acura in Nashua, NH and they said it was a faulty code from the Purge Control Sensor. $248 smackers to fix. Thinking I can buy the sensor online and replace myself? Anyone have luck with this? Thanks
mkbqin is offline   Reply With Quote
The Following User Says Thank You to mkbqin For This Useful Post:
mixjuan (02-18-2012)
Old 08-16-2011, 8:36 AM   #28
pinatubo
Registered Member
Garage is empty, add now
 
pinatubo's Avatar
 
Trader Rating: (0)
Join Date: Jul 2010
Posts: 374
Thanks: 0
Thanked 8 Times in 8 Posts
Points: 3,808, Level: 39
Points: 3,808, Level: 39 Points: 3,808, Level: 39 Points: 3,808, Level: 39
Activity: 0.7%
Activity: 0.7% Activity: 0.7% Activity: 0.7%
Hmmmm, acura .... acura ...... acura ..... tsk
Should I start saying Acura suck?
Just this morning, started the engine to go to work, surely there was (and still there is) "Tighten Fuel Cap" message on the MID. It just showed up from nowhere, my gas tank is about 2/3, never hit this problem on 10K driving miles, but now.
I hope it is not a critical issue but according to those posts above, acura charging us for their faulty problems? Hmmmm, I thought they MUST constantly apologize their customers and get it fixed ASAP w/o any charge.
Just a year in, and having 2 problems so far. I don't know how much I would spend if I keep it until pay off.
Disappointed.
pinatubo is offline   Reply With Quote
Old 09-09-2011, 7:34 PM   #29
LoveLovelyTL
New Member
2006 Acura TL
My Garage
 
Trader Rating: (0)
Join Date: May 2011
Age: 28
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 256, Level: 5
Points: 256, Level: 5 Points: 256, Level: 5 Points: 256, Level: 5
Activity: 0.1%
Activity: 0.1% Activity: 0.1% Activity: 0.1%
I have an 06 TL and have had my car for over a year and its got high mileage.. 110k but never have I seen this message until this afternoon and its staying on regardless. I even topped it off thinking maybe I got some bad gasoline. I called my friend at Acura and he said same thing "Purge Control Valve" I just think its so odd that it JUST now decided to come on. He said there was a service bulletin about it a little while back and they were encouraging everyone to get the part installed while getting other work done but at $200 and sounds like a manufacturing defect why the heck isn't Acura stepping up! This should be a recall not a bulletin. He said too bad I'm out of warranty because warranty replaces it for free. Argh.. oh well!
LoveLovelyTL is offline   Reply With Quote
Old 09-28-2011, 12:28 PM   #30
vmodi89
07 WDP TL Type S
2007 Acura TL
 
vmodi89's Avatar
 
Trader Rating: (0)
Join Date: Jun 2009
Location: Waltham, MA
Age: 24
Posts: 107
Thanks: 0
Thanked 14 Times in 12 Posts
Points: 4,544, Level: 42
Points: 4,544, Level: 42 Points: 4,544, Level: 42 Points: 4,544, Level: 42
Activity: 0.7%
Activity: 0.7% Activity: 0.7% Activity: 0.7%
has anyone come up with a definite fix for this? My 07 TL-s with about 45k on it is at Acura of Boston and they said it was the purge control solenoid. My car gets the "tighten gas cap" message about the third time i start the car (about 40 miles on the tank) after I fill up. They said it will be $328 to replace the solenoid.

I don't know if this is relative but I do have an AEM v2 cold air intake.
__________________
__________________
White Diamond 2007 TL Type S
8000k Headlights and Fogs | LEDs | AEM v2 CAI | 35% tint | JL Audio HD900/5 | JL Audio 12W6v2/custom box | USASpec PA-ACUXL iPod Integration | Independent Fogs | Black Roof | CompuStar 2-Way Alarm/Remote Start | A-Spec Kit | 18"x8.5" Aspec Wheels | Conti DWS
vmodi89 is offline   Reply With Quote
Old 10-13-2011, 9:55 AM   #31
njkode
Registered Member
Garage is empty, add now
 
njkode's Avatar
 
Trader Rating: (0)
Join Date: Jun 2011
Location: LA
Posts: 87
Thanks: 1
Thanked 2 Times in 2 Posts
Points: 2,395, Level: 29
Points: 2,395, Level: 29 Points: 2,395, Level: 29 Points: 2,395, Level: 29
Activity: 0.7%
Activity: 0.7% Activity: 0.7% Activity: 0.7%
Quote:
Originally Posted by beachbobe View Post
I have had this problem every summer for past 2 years. "Tighten Fuel Cap" msg appears intermittently especially when the air temp is above 80 degrees. After reading all the previous posts I gave the dealer the service bulletin number 09-056 that others have reported and they replaced purge solenoid. I live in pricey Boston area - out of warranty dealership price was $128 for parts and about $60 for labor. 2007 TL Hope this works!

does any one have a link to this service bulletin? I made an appointment for my car tomorrow but I'd like to bring this in with me if I can to avoid them trying to BS me.
njkode is offline   Reply With Quote
Old 02-18-2012, 7:39 AM   #32
mixjuan
New Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Feb 2012
Age: 43
Posts: 2
Thanks: 4
Thanked 0 Times in 0 Posts
Points: 177, Level: 3
Points: 177, Level: 3 Points: 177, Level: 3 Points: 177, Level: 3
Activity: 0.1%
Activity: 0.1% Activity: 0.1% Activity: 0.1%
Just came on - 2007 TL

Thank you all for all of the great information posted here. I was looking into this because mine just came on last night, randomly, after I had filled up and then driven until I was under half a tank. Never touched the cap after the fill up.

I tightened it when I got home and when I started up this morning, the message was still there. The car was already running and I removed the cap and re-tightened it. The notification went away after driving about 2 miles. Come to think of it, it was after I had just gone over 35mi/hr.

Not sure what that was about, but I thank Acura that they differentiated between a loose cap and the check engine light. I just bought this car 2 weeks ago and would be frustrated to already be having to deal with O2 sensors and whatnot.
mixjuan is offline   Reply With Quote
Old 02-18-2012, 4:31 PM   #33
nj2pa2nc
it's a car-drive it
Garage is empty, add now
 
nj2pa2nc's Avatar
 
Trader Rating: (0)
Join Date: Apr 2007
Location: North Carolina
Posts: 5,340
Thanks: 453
Thanked 252 Times in 190 Posts
pm me
Points: 9,184, Level: 64
Points: 9,184, Level: 64 Points: 9,184, Level: 64 Points: 9,184, Level: 64
Activity: 1.1%
Activity: 1.1% Activity: 1.1% Activity: 1.1%
went to the Wawa in NJ to get gasoline on Wed. Today with almost 100 miles the tighten gas cap message came on. The gas cap was loose so I tightened it. Hoping the message will go out
__________________
2006 MR/eb 6MT/wnav tsx (new 11/17/06) 166k
miles(regular gas), rear brakes replaced 1st time 150k miles front brakes still in great shape. Original owner-it is my official beach going, dog carrier vehicle. 2014 Kia Soul primo package (new -1/03/14) official roadtrip vehicle. (3K miles)
nj2pa2nc is offline   Reply With Quote
Old 04-16-2012, 1:08 PM   #34
gaytrin
New Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Apr 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 15, Level: 1
Points: 15, Level: 1 Points: 15, Level: 1 Points: 15, Level: 1
Activity: 0.2%
Activity: 0.2% Activity: 0.2% Activity: 0.2%
Sorry to reiterate but i'm having the same problem. I've a 2011 Acura TL and this message appeared for the 2nd time now. The first time during winter (and it was cold that day) and the second this morning (and it was extremely warm this morn, 80-85). Not sure if it's the pressure difference but it sure is scary. I scheduled yet another apt for the same prob. They tell me it could be a leak. will know this week. Also, there was no emission prob the last time they inspected my car for the same "fuel cap" alert. My car is barely a year old..and i'm dealing with probs already!
gaytrin is offline   Reply With Quote
Old 12-12-2013, 5:24 PM   #35
usdmJON
Registered Member
Garage is empty, add now
 
usdmJON's Avatar
 
Trader Rating: (0)
Join Date: Apr 2013
Posts: 2,012
Thanks: 96
Thanked 200 Times in 162 Posts
Points: 2,568, Level: 30
Points: 2,568, Level: 30 Points: 2,568, Level: 30 Points: 2,568, Level: 30
Activity: 39.8%
Activity: 39.8% Activity: 39.8% Activity: 39.8%
My 2013 ilx is doing the same so I guess it is officially every acura model that can experience this.

I too havent touched the gas cap in at least a week so it was pretty random. Figure ots just tje weather...
__________________
..Check out my ILX Progress Thread here..

Quote:
Originally Posted by neveronlineilx View Post
..don't want others whom lack imagination and have more spending money than me to bite ideas..
usdmJON is online now   Reply With Quote
Old 01-02-2014, 4:33 PM   #36
davidspalding
Make a hole, coming thru!
2006 Acura TSX
 
davidspalding's Avatar
 
Trader Rating: (0)
Join Date: Aug 2007
Location: Somewhere between 70 and 125 mph
Posts: 2,917
Thanks: 16
Thanked 8 Times in 6 Posts
Points: 11,705, Level: 71
Points: 11,705, Level: 71 Points: 11,705, Level: 71 Points: 11,705, Level: 71
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
I just had this happen on my 2006 TSX (140k), while driving long distance (stopped at Chick-fil-a, and it came on when we started up to leave). No big temperature changes. About half a tank remaining.

Checked cap. Snug. Drove another 30-40 miles. Still on.

On for the duration of the return trip (130m). Filled tank near home (none of that stoopid "topping off" nonesense). No change.

RTFM ... the manual says the MID "Tighten filler cap" warning may take several days to go away. If the CEL comes on, report to dealer with credit card locked 'n loaded. Hmph. Pfft! Turned on ignition the next morning (full tank), same MID message came up immediately. "Wait several days," my arse....

My solution: I disconnected the battery for 20 minutes. Reconnected battery, fired up, entered radio code and set clock, drove 30m to work, no more warning. (I disconnect the battery from time to time, as I understand it clears the ECU's "memory" of driver behavior that it "learns" from. No, I can't cite my reference.)
__________________
-- (/\) -- 2006 TSX 5AT; ASM Q; A-spec dampers; Progress RSB; Fastline steel brake lines; RB ET500 pads; Hondata; Gtech-Pro RR; an' no stinkin' badges.
Member, NCR-SCCA - THSCC. Drive safely on public highways, use tracks for pushing the envelope. Just because I can do CPR, doesn't mean I want to.
davidspalding is offline   Reply With Quote
Old 01-03-2014, 6:49 AM   #37
Simba91102
Old Guy
1985 Ferrari 308
My Garage
 
Simba91102's Avatar
 
Trader Rating: (0)
Join Date: Apr 2007
Posts: 2,677
Thanks: 0
Thanked 142 Times in 123 Posts
Points: 9,040, Level: 63
Points: 9,040, Level: 63 Points: 9,040, Level: 63 Points: 9,040, Level: 63
Activity: 9.3%
Activity: 9.3% Activity: 9.3% Activity: 9.3%
Quote:
Originally Posted by davidspalding View Post
I just had this happen on my 2006 TSX (140k), while driving long distance (stopped at Chick-fil-a, and it came on when we started up to leave). No big temperature changes. About half a tank remaining.

Checked cap. Snug. Drove another 30-40 miles. Still on.

On for the duration of the return trip (130m). Filled tank near home (none of that stoopid "topping off" nonesense). No change.

RTFM ... the manual says the MID "Tighten filler cap" warning may take several days to go away. If the CEL comes on, report to dealer with credit card locked 'n loaded. Hmph. Pfft! Turned on ignition the next morning (full tank), same MID message came up immediately. "Wait several days," my arse....

My solution: I disconnected the battery for 20 minutes. Reconnected battery, fired up, entered radio code and set clock, drove 30m to work, no more warning. (I disconnect the battery from time to time, as I understand it clears the ECU's "memory" of driver behavior that it "learns" from. No, I can't cite my reference.)
As can be seen from the age of this thread (and I'm pretty sure there are more, on every forum), this is a brand wide phenomena (though fortunately not that common). It is one of the things that the old "disconnect the battery" trick will most often cure, though it usually will actually go off by itself eventually. I agree that weather can be a factor, plus, with the older cars, I wonder if it may be the cap itself.
__________________
If you think you're sick of "all plane, all the time" now, just wait till they find the friggin thing . . .
Simba91102 is offline   Reply With Quote
Old 01-03-2014, 6:49 AM
AcuraZine
Acura Integra




Paid Advertisement


 
 
 
submit to reddit
Reply

Tags
2006, acura, cap, cup, fuel, gas, hot, light, mdx, message, rdx, tighten, tl, tsx, warning

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 3:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Acurazine.com content, comments, or advertising. Acurazine.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Acurazine.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Passwords Backup